Accessing an article results in a 500 error
Symptoms
Accessing the a story results in a 500 error in the browser.
Cause
500 errors most commonly occur in the browser when the content source is unable to call or process information from the content source.
Solution
Troubleshooting this issue begins by isolating the error to the content source by verifying that content API returns valid data, and that a querying the content source directly with the same data results captured by the resolver results in the same error.
Verify that Content API returns valid data for the article:
Verify that the Content Source returns a 500 error:
Use PageBuilder Resolver Debugger with the story URL to verify the resolver that matches the story URL and determine if this is correct and expected.
From Resolver Debugger or the Resolver configuration, identify the content source configured for the matching resolver.
From the Resolver configuration verify that the regular expression is correct and that the match will result in correct data being captured by capture groups.
From the Resolver configuration, determine what information is being captured by the resolver and passed to the content source.
From Content Debugger, select the content source, and generate the same content source request by populating the data relevant to the failing request into the appropriate fields.
If no valid response is returned, open the inspector in the browser and examine the console or network tab for the same 500 errors.
Once the error has been attributed to the content source, troubleshooting should proceed on the content source. If Arc XP provided this content source, for example, Arc XP Themes, contact Arc XP Customer Support to request that we investigate. If the content source was developed locally, troubleshooting of the content source must occur locally, however reach out to Arc XP Customer Support regarding any questions or concerns you may have regarding content sources, resolvers, or content API.